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Updating EDI Engine
How to locate your EDI Engine Directory
You will need to know the location of your EDI Engine directory in order to perform program and document updates.
Open the EDI Engine shortcut icon Properties
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Right Click on the EDI Engine shortcut and select Properties.
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1) The file path location of your EDI Engine Directory is displayed in the Start in: field. You can copy this text to use when prompted to unzip to the EDI Engine directory while running the updater program.
2) Windows 7 allows you to Open File Location directly from the Properties dialog box. You will have to follow the file path to open the EDI Engine directory in other operating systems.
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There are several important sub directories (filemaps, labels and maps) within the EDI Engine directory that you will need to be familiar with. 
When we send you a document update, i.e., a revised filemap, label, or map, you will need to locate the old document that is already in the filemaps, labels or maps directory and save a copy to the backup location of your choice. 
Then you will copy and replace the updated document into the appropriate folder.
How to update your EDI Engine Standard/Professional Edition
This lesson will show you how to update your EDI Engine to the latest build released.
Backup the EDI Engine Directory
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Before you begin the update, backup the EDI Engine directory (1). Contact your network administrator for assistance with backup procedures.
See, "How to Locate your EDI Engine Directory",  for tips on finding your EDI Engine Directory file path.
Make sure all users are completely out of EDI Engine
Confirm that all known users (local and remote) have closed the EDI Engine program. If any user is still logged in the program will not update properly.
Download the EDI Engine updater program from the 123 EDI Download Site
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Go to the 123 EDI Download website at http://www.ediengine.com and review the Installation Instructions.
1) Click on the link that reads, "Click here to download update" to download the EDI Engine Standard/Professional Edition updater program
2) Check out the Release Notes link for a list of many of the EDI Engine fixes and enhancements made in the last year. 
Save the EDI Engine updater program
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Click Save.
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We recommend saving the EDI Engine updater file to your desktop - its an easy place to find it.
1) Select Desktop.
2) Click Save.
Open the EDI Engine updater program that was just download.
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Double click on the EDI Engine updater program icon to run EDI Engine updater.
Review Installation Instructions
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Review Installation Instructions and click OK.
Unzip the update to the EDI Engine Directory
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1) Enter the EDI Engine Directory file path. See, "H<a>ow to Locate your EDI Engine Directory",  for tips on finding your EDI Engine directory file path.
2) Click Unzip.
Enter the EDI Engine Standard/Professional updater password
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1) Enter the EDI Engine Corporate Edition updater password. If you do not know the password, contact your Project Manager, create a ticket on the Support Help Desk,or e-mail support@123edi.com.
2) Click OK.
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Click OK.
EDI Engine License information
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The EDI Engine license will open automatically. It can be reviewed and closed.
Open EDI Engine
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You will be prompted to update the database. Click Yes.
Successful Update
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1) Click OK to confirm successful update.
2) The Data Update report contains detailed information on fields updated. Unless instructed by a support agent you can close this file.
Verify the Version Build Date
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Select Help > About EDI Engine...
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1) This Build Date should match the Version Date listed on the 123 EDI Download Site, http://www.ediengine.com.
2) Click Ok to close EDI Engine info box.
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This Version Date should match the Build Date listed in the About EDI Engine... window of your EDI Engine program.
How to Update a Map
This lesson will show you step by step how to update a map sent from 123 EDI.
Download the Updated Map sent from 123 EDI
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1) Download the compressed folder containing the Updated Map (ex. 880_out_4010_publix.FXP) that you received from 123 EDI.
This image shows the Compressed (zipped) Folder being downloaded from a hotmail account.
Save the Updated Map to the Desktop
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1) Select Desktop.
2) Click Save.
Locate the Original Map to save a copy before updating
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In your EDI Engine directory(1) there is a Maps directory(2) where all the Maps used by your company are stored. In this example the ediengine directory is on the Local Disk (C:). See "How to locate your EDI Engine directory" for tips on finding the maps directory.
1) Click on the ediengine directory to open.
2) Click on the maps subdirectory to open.
3) Select the original filemap (ex. 880_out_4010_publix.FXP) .
Backup the Original Map before updating
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1) Right click on the original map (ex. 880_out_4010_publix.FXP). 
2) Select Copy.
Backup the Original Map before updating
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1) Open the backup directory of your choice. Or, if you don't already have a backup directory create a new subdirectory for old maps in the maps directory. In this example I opened old, a subdirectory of maps that was created for map backups. (C:\ediengine\maps\old).
2) Right click in the folder.
3) Select Paste to copy the original map to this directory.
Open the Compressed Folder containing the Updated Map
[image: image24.png]i h ="
)< ediengine » maps »

] scorch moes

<1 BT

File Edt View Tools Help

] 880_out 4010_publicprg  6/5/2003 5:22 PM

] 880_out 4010_shaws.FXP  6/27/2006 1:49 PM
] 880_out 4010 Shaws.prg  3/15/2006 1206 PM
] 880_out S010_publicFXP  6/27/2006 1:49 PM

[ 880_out 5010_publixprg  6/17/2006.9:28 AM |
] 940_out 4010 _atomicboxF...  6/27/2006 1:49 P

i queres 71,080 st 4010 stomichee ner 10/5/2005 031 &M
Ui reports Salzi »
880_0ut 4010_publiFXP Date modifiec: 6/27/2006 1:49 PM
FXP File Size: 844 KB

Organize»  []Open v Bum  Newfolder =+ A @
&, Local Disk (C) ~ Name ’ Dstemodified ~ * “Type: Compressed (zipped) Folder
B edfengine o = Size344K8
B oo [ 875.in 4010 shaws.FXP  6/27/2006 149 PM Date modifiec: 12/8/2010 8:56 AM
| B oo 1 875.in 4010 shaws prg 3/13/2006 650 PM
B e [ 875.in S00_publixFXP  6/27/2006 149 PM
875.in_5010_publi 6/5/2006 1205 PM
B datasct L 75.in 3010 _publiprg
[ 880_out 4010_brookshireF.. 6/27/2006 1:49 PM
B datasinglecompany
B o ] 880_out 4010 Brookshireprg 11/17/2004 339 PM
e o ] 880_out 4010_c&us P 62772006149 PM
" ] 880_out 4010_cBis prg 8172002501 PM
]880_out 4010 publixFXP  6/27/2006 1:49 PM

Z EE e E

857 AM
12/8/2010





1) Click on maps to return to the maps directory.
2) Double click on the Updated Map Compressed Folder to open it.
Copy Updated Map to EDI Engine Maps Directory
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1) Select the Updated Map (ex. 880_out_4010_publix.FXP) from the compressed folder that was downloaded to the desktop.
2) Drag it to the EDI Engine maps directory (ex. C:\ediengine\maps).
Copy and Replace
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Select Copy and Replace to replace the Original Map that was just backed up with the Updated Map you received from 123 EDI.
Map Updated
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Your Map will be updated the next time you open EDI Engine.
Delete Compressed Folder
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You can delete the Updated Map Compressed Folder.
1) Right click on the Compressed Folder
2) Select Delete
How to Update a Filemap
This lesson will show you step by step how to update a filemap sent from 123 EDI.
Download the Updated Filemap sent from 123 EDI
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1) Download the compressed folder containing the Updated Filemap (ex. in_text_delimited.FXP) that you received from 123 EDI.
This image shows the Compressed (zipped) Folder being downloaded from a hotmail account.
Save the Updated Filemap to the Desktop
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1) Select Desktop.
2) Click Save.
Locate the Original Filemap to save a copy before updating
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In your EDI Engine directory(1) there is a Filemaps directory(2) where all the Filemaps used by your company are stored. In this example the ediengine directory is on the Local Disk (C:). See "How to locate your EDI Engine directory" for tips on finding the filemaps directory.
1) Click on the ediengine directory to open.
2) Click on the filemaps subdirectory to open.
3) Select the Original Filemap (ex. in_text_delimited.FXP).
Backup the Original Filemap before updating
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1) Right click on the Original Filemap (ex. in_text_delimited.FXP).
2) Select Copy.
Backup the Original Filemap before updating
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1) Open the backup directory of your choice. Or, if you don't already have a backup directory create a new subdirectory for old filemaps in the filemaps directory. In this example I opened old filemaps, a subdirectory of filemaps that was created for filemap backups (C:\ediengine\filemaps\old filemaps).
2) Right click in the folder.
3) Select Paste to copy the Original Filemap (ex. in_text_delimited.FXP) to this directory.
Open the Compressed Folder containing the Updated Filemap
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1) Click on filemaps to return to the filemaps directory.
2) Double click on the Updated Filemap Compressed Folder to open it.
Copy Updated Filemap to EDI Engine Filemaps Directory
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1) Select the Updated Filemap (ex. in_text_delimited.FXP) from the compressed folder that was downloaded to the desktop.
2) Drag it to the EDI Engine filemaps directory (ex. C:\ediengine\filemaps).
Copy and Replace
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Select Copy and Replace to replace the Original Filemap that was just backed up with the Updated Filemap you received from 123 EDI.
Filemap Updated
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Your Filemap will be updated the next time you open EDI Engine.
Delete Compressed Folder
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You can delete the Updated Filemap Compressed Folder.
1) Right click on the Compressed Folder
2) Select Delete
EDI Engine Daily Operations
Receiving EDI Data and Sending Functional Acknowledgments
This lesson will show you step by step how to receive EDI Data and send Functional Acknowledgments.
Open the File Navigator
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Click on the File Navigator menu button.
From the File Navigator . . .
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1) Click Inbound.
2) Click Receive.
Select the desired Conduits
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1) Tag the Conduits you want to receive data from by clicking in the Tag column box.
4) Click Proceed.
Processing Log generated
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After the communication process ends, the Log Report window will appear.
1) The processing log that was just created will be highlighted at the top of the list. This log will contain all of the details of the completed task. 
2) Unless you are instructed to use the log you can click Cancel to close the Log Report.
Import the file(s) into EDI Engine
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1) Click Tag All (or manually check the box in the Tag column for the files you want to import into EDI Engine).
2) Click Import File/s into EDI Engine. 
Processing Log generated
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After the files are imported into EDI Engine, the Log Report window will appear.
1) The processing log that was just created will be highlighted at the top of the list. This log will contain all of the details of the completed task. 
2) Unless you are instructed to use the log you can click Cancel to close the Log Report.
Send Functional Acknowledgments
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After successfully importing the file(s) into EDI Engine, Functional Acknowledgments will be created automatically.
1) Click Outbound.
2) Tag the newly created Functional Acknowledgment.
3) Click Send.
Confirm sending
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Click Yes.
Processing Log generated
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After the Functional Acknowledgment files are sent, the Log Report window will appear.
1) The processing log that was just created will be highlighted at the top of the list. This log will contain all of the details of the completed task. 
2) Unless you are instructed to use the log you can click Cancel to close the Log Report.
Unknowns in the File Navigator
Unknown files in the File Navigator may be a result of a new trading partner that is not setup, a new transaction set received, incorrect IDs (testing moved to production without changing IDs), or a corrupt file. The following lesson will show you what to do when you find an unknown file in the File Navigator.
Open Unknown file in File Navigator
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1) Open the File Navigator by clicking on the File Navigator icon beneath the menu bar.
2) Double click on the unknown file to open it.
Send Unknown File to 123 EDI Help Desk - Option 1 Copy and Paste text
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You can either copy and paste the text of an unknown file or attach it to a Help Desk ticket at http://support.123edi.com or send an e-mail to support@123edi.com.
To copy and paste the Unknown File text press Ctrl + A to select all, Ctrl + C to copy, and then Ctrl + V when ready to paste text to e-mail or 123 EDI Help Desk ticket.
Send Unknown File to 123 EDI Help Desk - Option 1 Paste Unknown File in ticket
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Log on to the 123 EDI Help Desk at http://support.123edi.com.
1) Select SUBMIT A REQUEST.
2) Enter Request Subject.
3) Press Ctrl + V to paste the Unknown File text into the Description field of the ticket.
4) Select Priority.
5) Click Submit.
Send Unknown File to 123 EDI Help Desk - Option 2 Attach file
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You can either copy and paste the text of an unknown file or attach it to a Help Desk ticket at http://support.123edi.com or send an e-mail to support@123edi.com.
To attach the Unknown File open the File menu and select Save As...
Send Unknown File to 123 EDI Help Desk - Option 2 Attach file (Save to Desktop)
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1) Select Desktop (it's an easy place to find the file when attaching to an e-mail or Help Desk ticket).
2) Click Save.
Send Unknown File to 123 EDI Help Desk - Option 2 Attach file (Create ticket)
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Log on to the 123 EDI Help Desk at http://support.123edi.com.
1) Select SUBMIT A REQUEST.
2) Enter Request Subject.
3) Enter Description.
4) Select Priority.
5) Click Attach file(s).
Send Unknown File to 123 EDI Help Desk - Option 2 Attach file
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1) Click Choose File.
2) Select Desktop.
3) Select Unknown File.
4) Click Open.
Send Unknown File to 123 EDI Help Desk - Option 2 Attach file (Submit Request)
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Click Submit.
Close Unknown File
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Click on the X in the upper right corner.
Archive Unknowns in File Navigator
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From the File Navigator (1)
2) Tag the documents you want to archive.
3) Click Archive.
Document Navigator Introduction
This lesson will introduce you to the Document Navigator and show you step by step how to view, print, process, archive, and unarchive documents in EDI Engine.
Open the Document Navigator
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Click on the Document Navigator menu icon.
Document Navigator parameters explained
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Documents can be viewed based on the criteria in the left section of the screen as follows:
1)
Direction (Inbound or Outbound)
2)
Document Type (Purchase Order, Invoice, ASN, etc…)
3)
Document Status (New, Processed, Ready, On Hold)
4)
Document Creation Date in EDI Engine
5)
Document Status (Accepted, Accepted With Errors, Rejected, Not Acknowledged)
6)
Trading Partner
To View a document . . .
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In this example we are opening a Purchase Order that is both New and Ready.
1) Double click in any of the first five columns of the document to view it.
To Print a document . . .
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1) To print a document or multiple documents, tag them individually OR (2) Click Tag All.
3) Click Print Document.
To Print a document - Number of Copies
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1) Enter the Number of Copies.
2) Click Print.
To Print a document - Choose Printer
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1) Select the printer you want to print to.
2) Click Ok.
To mark document Processed
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1) Tag the document by clicking in the Tag column box.
2) Click -> Processed.
Confirm Mark as Processed
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Click Yes.
To Archive Processed documents . . .
[image: image66.png]File Edit EDI Reports Window Help

|8

|(o]E]=) &) X] (]

W] ] ] (4]

rom | 11302010

Onfol 7o [ 12302010
Status of Acknowledgments
an =
AllTrading Partners.
B85 [Bed Bath and Beyond A
cosco lcostco.com
CSNSTORES  |cSN Stores.
ECWORLD  [EC Workd
ECW_0S [Ec work-overstock
JCPENNEY [ic Penney
MEUERS eiers
oovw (Offce Depot Vitual Warehouse
OFFICEMAX  [0ffce Max
QuLL loun
SeARS Sears
SEARSHOLD  [sears holding (Kmart_
STAPLES  [Stapks
STAPLESCOM _[Stapies.com
TARGET [rarget
TARGETOVS  [Target.com

S T

Search)

‘Type Trading Partner Document Source Document Created _Modified _Status (ED)) ~

WA 850 SRS [EE] T2/2972010 7213072010 ]
« [ » N
([ont Document ] (Prnt pick Ticket
Eol Status Hanager
[ copyDocument ] [P0 Confirmation (0ut 855) | [PO Retur AckiOut 18
Export ubound 0| [t (s smernaon]
[ owottooonc ] [Werehause Order (0ut540) |
EportoTO ] | voces Oue0) | [ Ouokass outese) |

o




Document that are “Processed” and “Ready” can be archived
1) Click Processed and Ready.
2) Click Tag All.
3) Click Archive.
Confirm Archive
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Click Yes.
To access Archived documents
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1) Open File > Maintenance > Documents > Unarchive.
To Unarchive a document
[image: image69.png]File Edit EDI

Reports Window Help

|8

8||clal=) @] ] [ In] # ][4

Document Types

[ DA ) nsoni ]

Tag Type Trading Partner _Document Location

Date Archived T~

/1 )850 SEARS

4134751

Z0T0DECENBERQDT 22972010 041019 PIl 12602010 |

850 TARGETDVS

20
20

530
2
50
52
a5
a5
260
251

[Payment OrderiRemitance Advice
|appication Advice

[Fnancil Return Notice

[Planning Scheduie

Price Sales Catalog.

lPurchase Order

[Product Actiiy Data

lPurchase Order Acknowledgment
|agvance stip Notice:

[Purchase Order Change.
[Receiving Advice.

111302010 12302010

T

(Trading Partners.

B85 [Bed Bath and Beyond
cosco lcostco.com

CSNSTORES  |cSN Stores.

ECWORLD  [EC Workd

ECW_0S [Ec work-overstock
JCPENNEY [ic Penney

MEUERS eiers

oovw (Offce Depot Vitual Warehouse
OFFICEMAX  [0ffce Max

QuLL loun

SeARS Sears

SEARSHOLD  [sears holding (Kmart_
STAPLES  [Stapks

STAPLESCOM _[Stapies.com

TARGET [rarget

TARGETOVS  [Target.com

Unarchive Manager

| [ —— |

D4HPhXIR 2010DECEMBER0D1 1210112010 1051:18 AM 1213012010 (

= Jsearch Document Number

o




1) Select the parameters for the document you want to unarchive (same as above with Document Navigator).
2) Tag the document.
2) Click Unarchive.
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Click Yes.
Confirm Unarchive
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Click OK.
Close Unarchive Manager
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Click on the X to close.
Unarchived Document returns to previous status
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After Unarchiving this order, it is returns to the (1) Processed and Ready status view where is was originally (2) Archived from.
Checking Logs
This lesson will introduce you to the various logs generated by EDI Engine and show you how to transmit important information to our technical support Help Desk.
Open the Log Report
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Open Reports and select Processing Log.
Log Report Options
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After every process in EDI Engine, the “Log Report” window appears.
1) The most recent process will be highlighted at the top of the list.
2) If you are sending a log to the Help Desk you will need to send the entire log. Do not check the Only Entries with Errors box.
3) Click Process to view highlighted log.
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This processing log shows:
1) The Date and Time the Process was preformed
2) The Process
3) Any Errors in the process are indicated by "Yes"
4) Details of the document
5) Details of the process
The following are the most common processes:
COMM_RCVD: Communication Receive
COMM_SEND: Communication Send
EDI_IN: Importing EDI raw Data into EDI Engine
EDI_OUT: exporting documents to EDI
Sending a log to Technical Support
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If a tech support agent has requested that you send a processing log you can either copy and paste the contents of the log in an e-mail or Help Desk ticket or save it to your desktop to attach to an e-mail or Help Desk ticket.
1) To Copy and Paste the log: press Ctrl + A to select all; press Ctrl + C to copy; then press Ctrl + V to paste the log text into an e-mail or Help Desk ticket.
2) To Save the log to your desktop: Open the File menu and select Save As...
Saving a log
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1) Select Desktop.
2) Enter a file name.
3) Click Save.
Once you have saved a log to your desktop you can easily find it to attach it to an e-mail or Help Desk ticket.
Close Processing Log
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Click the X in the upper right corner to close the processing log.
Reports
EDI Engine is equipped with three reports, the Transmission Summary Report, Reconciliation of Functional Acknowledgments, and Management Report, that ensure the precision of the day to day operations.
Transmission Summary Report
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The Transmission Summary Report list all the transmission you have received from all your trading partners. 
From the menu bar open Reports > EDI > Transmission Summary.
Select Date Range
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1) The report by default lists the transmissions of the last 30 days, though you can change the date range.
2) Click Process.
Transmission Summary Report View Options
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You can view the result on the Screen in a notepad or in the formatted Print Preview or you can Print the report.  
Print Preview of Transmission Summary Report
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Any transmission received has an ISA Control number and a GS control number. The control numbers are usually in sequence. The sequence can be either by trading partner only or by Trading partner and document type.
1) You can print the report by clicking on this print icon.
2) To close the report, click on the X in the upper right corner.
Open Reconciliation of Functional Acknowledgments
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The Reconciliation of Functional Acknowledgments report list all the unacknowledged transmission that were exported to EDI from EDI Engine. Each transmission sent from EDI should be acknowledged within 24 hours. If the reports shows any unacknowledged documents after 24 hours of their transmission, contact the trading partner immediately to ensure the receipt of the document.
1) From the menu bar choose Reports > EDI > Reconciliation of Functional Acknowledgments.
Process Reconciliation of Functional Acknowledgments
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1) This report can be viewed by trading partner and by document type.
2) By default, the report lists the transmissions that were Accepted but with (E)rrors, (R)ejected, and (N)ot Acknowledged for all trading partners during the last week.
3) Click Process.
View Reconciliation of Functional Acknowledgments
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Once processed you can either Print, see a formatted Print Preview (that can you also print from), save the report as an Excel File or view the report on Screen in the notepad.
Print Preview of Reconciliation of Functional Acknowledgments
[image: image87.png]DI Engine - RTA Products [_[o]
Fle Edt EDI ParcelShipping Quickbooks Reports Window Help

k2] ] [ [ | ] ]

12/31/2010

P 16:59:58 REQUESTED ACKNOVLEDGEMENTS REPORT

Type  Document Trms 1D Trmx ID  Trmx 1D Original  Last
Ho. Date & Time Sent (158 (8 (5T Status  Status

TARGETDVS
855 DvPszXanR 12/09/2010 000003744

=

Recardt EOF/1 Exclusive





The unacknowledged documents will have the Letter “N”, the Documents accepted with errors will have the letter “E”, and the rejected documents will have the letter “R”.
Each document has 2 statuses, the “Original Status” and the “Last Status”.  If you send a document more than one time, the original status will show the first acknowledgment status while the last status will show the current status after the second transmission.
Management Reports
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EDI Engine comes with several management reports for the Purchase Orders, Invoices and Advanced Ship Notices.  These reports can be accessed from the menu bar by selecting Reports > Management Reports.
E-mail Connectivity
This lesson will show you how to edit your e-mail notification settings and send a test e-mail.
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From the menu bar, open EDI > Setup > Company.
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1) Select the Email Notification tab.
2) Enter recipients separated by semicolon.
3) Click Send Test Email.
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